Spam Problem im Forum

MyOOS hat einen Fehler, oder tut nicht das, was Ihr erwartet? Derartige "Unanehmlichkeiten" bitte hier.
Antworten
r23
Beiträge: 2718
Registriert: 18.09.2008, 05:56
Wohnort: Hagen
Kontaktdaten:

Spam Problem im Forum

Beitrag von r23 »

Hallo,

Google hat vor wenigen Tagen ein neues Sicherheitssystem eingeschaltet.
viewtopic.php?t=5488

Ein gmail Anwender konnte sich im Forum leider nicht anmelden. Ich habe die Konfiguration von dem Forum geändert und bekomme jetzt eine Spamflut mit.

Ich verbringe meine Lebenszeit nicht damit, russische Spammails zu löschen. :oops: Der MOD Anwender, der sich nicht anmelden konnte, hat sich selbstverständlich nicht angemeldet. :evil:

Die erste Idee war, das Problem müssten andere phpBB Anwender auch haben. Sinnvolle Lösungen habe ich auf die schnelle bedauerlicherweise nicht gefunden.

Die Trolle geben sich noch nicht mal mehr mühe und schreiben ihren Datenmüll auf Russisch.

Die zweite Überlegung ist - man kann die verwendete Sprache in einem Beitrag erkennen und dann einfach den Beitrag nicht speichern ;) :mrgreen:

Blick in die Quellen von phpBB3 - upps - man findet überhaupt nichts mehr. :?

1. Gibt es vielleicht irgendwo eine Anleitung, wie man eine Erweiterung für phpBB3 schreibt? Dann könnte ich diesen "Spamfilter" anderen auch zur Verfügung stellen.

2. Evtl. erfinde ich das RAD hier neu und es gibt bereits eine gute Lösung für phpBB3? 8)


Beste Grüße

Ralf
MK70
Beiträge: 76
Registriert: 05.02.2021, 16:11

Re: Spam Problem im Forum

Beitrag von MK70 »

Hallo Ralf,

bei phpBB bin ich raus, da ich damit nicht wirklich arbeite (Woltlab "Jünger") :mrgreen:
Andere bitte vor :wink:
r23
Beiträge: 2718
Registriert: 18.09.2008, 05:56
Wohnort: Hagen
Kontaktdaten:

Re: Spam Problem im Forum

Beitrag von r23 »

MK70 hat geschrieben: 02.02.2024, 12:46 arbeite (Woltlab "Jünger") :mrgreen:
Woltlab hatte ich auch einmal.

Eine Anmeldung mit GMAIL, WEB.DE und YAHOO.de war hier augenscheinlich nicht möglich.

Ich habe GMAIL und YAHOO eingeschaltet. Jetzt wird das Forum mit Postings in kyrillischer Schrift geflutet. Vor ein paar Wochen haben die Spammer sich wenigstens noch Mühe gegeben und haben ChatGPT Übersetzungen verwendet.

ein Teil der MOD Anwender können sich zwar eine MySQL Datenbank leisten, müssen aber für ein Forum auf eine Gmail Adresse zurückgreifen? Auf die Idee muss man erst einmal kommen. Google ist Teil des Problems und nicht die Lösung.

Ich habe jetzt die Stelle in dem PHP Script gefunden, wo ich die Spam-Schutzprüfungen mir einbauen kann. Inspiration hole ich mir bei Anti-Spam Bee aus WordPress. Die Spracherkennung liegt aber auf dem Server vom Plugin Entwickler ;( hüst - er wird sich über phpBB Anfragen sicherlich sehr freuen ;)

An diesem Wochenende wird dies geändert.
MK70
Beiträge: 76
Registriert: 05.02.2021, 16:11

Re: Spam Problem im Forum

Beitrag von MK70 »

Ich nutze Woltlab seit ca. 2003, vorher war es ein Jahr Forennet.org (Forenhoster mit YabbSE Software).

GMail, Outlook, etc. - Alles Adressen, die zu leicht angelegt werden können, ohne Prüfung wer dahintersteckt. Leider.

Passend zu den Foren habe ich Fragen als Captcha eingestellt. Die halten das Forum sauber, weil diese nicht immer von Bots beantwortet werden können. Wenn ich meerke, dass das irgendwann nicht mehr hilft, werde ich ne Sperre einbauen. Sprich 1 Beitrag in einem bestimmten Forum ist frei, der muss moderiert werden und erst nach Prüfung, kann der jenige durch eine höhere Benutzergruppe mehr machen. PN sind z.B. am Anfang auch nur eingeschränkt möglich, da man darüber auch genug Spam verschicken könnte. :wink:
r23
Beiträge: 2718
Registriert: 18.09.2008, 05:56
Wohnort: Hagen
Kontaktdaten:

Re: Spam Problem im Forum

Beitrag von r23 »

Hallo,

ich habe jetzt eine PHP Klasse gefunden, mit der ich mit PHP prüfen kann, in welcher Sprache der Beitrag verfasst wurde.

cool :) ich muss keine Daten an Cloud Dienste senden und es funktioniert auch ohne KI.

Weil ich ja Langeweile habe, schreibe ich für die Google Anwender - grummel - eine phpBB Erweiterung. Verständliche Anleitungen habe ich bis jetzt nicht gefunden.

Ich erstelle mir jetzt etwas mit heißer Nadel, lege es aber ins phpBB3 Projekt ab - in der Hoffnung, dass phpBB3 Entwickler Verbesserungen einreichen.

jetzt wird es hier etwas WILD - sorry..
r23
Beiträge: 2718
Registriert: 18.09.2008, 05:56
Wohnort: Hagen
Kontaktdaten:

Re: Spam Problem im Forum

Beitrag von r23 »

Um in einer phpBB 3 Erweiterung dein eigenes Composer zu verwenden, musst du einige Schritte beachten. Ich habe im Internet nach einer Anleitung gesucht und folgendes gefunden¹:

- Erstelle einen Ordner für deine Erweiterung unter ext/<autor-name>/<extension-name>/.

- Erstelle eine composer.json-Datei in diesem Ordner, die die Informationen über deine Erweiterung enthält. Du kannst die [phpBB Skeleton Extension](^2^) als Vorlage verwenden.

- Führe den Befehl "composer require" aus, um die Abhängigkeiten deiner Erweiterung zu installieren. Achte darauf, dass du die richtige PHP-Version und die erforderlichen Erweiterungen hast.

- Führe den Befehl "composer dump-autoload" aus, um die Autoload-Datei deiner Erweiterung zu generieren.

- Aktiviere deine Erweiterung im Administrations-Bereich unter Anpassen -> Erweiterungs-Verwaltung -> Erweiterungen.

Bitte beachte, dass phpBB 3.3.3 Composer 2 verwendet, was zu Konflikten mit einigen Erweiterungen führen kann. Wenn du dieses Problem hast, kannst du versuchen, Composer 1 zu verwenden oder auf eine neuere Version von phpBB zu aktualisieren³.

(1) Extensions — phpBB 3.3.x documentation. https://area51.phpbb.com/docs/dev/3.3.x/extensions/.
(2) Installationsanleitung für eine Erweiterung (Extension) - phpbb.de. https://www.phpbb.de/kb/viewarticle?a=29.
(3) phpBB • SOLVED Extensions are not showing up. https://www.phpbb.com/community/viewtopic.php?t=2607191.


Unsere Erweiterung liegt in dem Verzeichnis
~/ext/myoos/myoos-antispam
r23
Beiträge: 2718
Registriert: 18.09.2008, 05:56
Wohnort: Hagen
Kontaktdaten:

Re: Spam Problem im Forum

Beitrag von r23 »

Postings in einer bestimmten Sprache werden hier nicht mehr gespeichert und müssen von mir auch nicht mehr gelöscht werden.

So können wir zumindest zurzeit das Forum für GMAIL Anwender offen halten :(

Beste Grüße

Ralf
MK70
Beiträge: 76
Registriert: 05.02.2021, 16:11

Re: Spam Problem im Forum

Beitrag von MK70 »

*Daumen*
:wink:
r23
Beiträge: 2718
Registriert: 18.09.2008, 05:56
Wohnort: Hagen
Kontaktdaten:

Re: Spam Problem im Forum

Beitrag von r23 »

Hallo,

ich finde es relativ überraschend, dass man mit einer 26 K kleinen Datei mit dem Inhalt

{"freq":{"D":565432,"E":313466,"F":303463,"G":350968,"A":448295,"B":452862,"C":218833,"L":272371,"M":385363,"N":224760,"O".... usw.

die Sprache DEUTSCH erkennen kann!

Leider habe ich den Filter nur mit einem Holzhammer eingebaut und kann dies unmöglich teilen :(

Hier habe ich aber zurzeit Ruhe...

Schönes Wochenende

Ralf
Antworten