Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet!

Gängige WordPress-Fehler und ihre Lösungen. Jeder WordPress-Anwender, der gerne Plugins und Themes neu installiert oder ändert, kennt das Problem. Unweigerlich taucht irgendwann ein Fehler auf.
r23
Beiträge: 1518
Registriert: 18.09.2008, 05:56
Wohnort: Hagen
Kontaktdaten:

Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet!

Beitragvon r23 » 04.09.2015, 03:30

Hallo,

nach dem Update auf WordPress 4.3 oder bei der Installation eines neuen Themes oder Plugins taucht diese Meldung auf

Notice: Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet! Verwende stattdessen __construct(). in ./wp-includes/functions.php on line 3457

Wir suchen in der Regel in den Quellen nach $this->WP_Widget und finden zum Beispiel

Code: Alles auswählen

$widget_ops = array('description' => __('Use this widget to add a vCard', 'crum')); $this->WP_Widget('vcard_widget', __('Crumina: vCard', 'crum'), $widget_ops);
Ab der Version 4.3. verwendet man allerdings:

Code: Alles auswählen

$widget_ops = array('description' => __('Use this widget to add a vCard', 'crum')); parent::__construct('vcard_widget', __('Crumina: vCard', 'crum'), $widget_ops);

Jetzt bist du gefragt!

Hat dir die Lösung auch geholfen das Problem zu beheben? Hast du Anregungen, Ergänzungen, einen Fehler gefunden oder ist dieser Beitrag nicht mehr aktuell? Dann freuen wir uns auf deinen Kommentar.


Beste Grüße

Ralf

mabola
Beiträge: 1
Registriert: 07.11.2016, 19:49

Re: Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet!

Beitragvon mabola » 07.11.2016, 19:53

Super, ich habe die Probleme damit beheben können.
Aber als Laie habe ich mit der Beschreibung "Quelle" erst mal nichts anfangen können.
Gerne noch etwas genauer den Weg zur Lösung beschreiben.
Aber eine super Hilfe!

nadine287
Beiträge: 1
Registriert: 04.01.2017, 18:37

Re: Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet!

Beitragvon nadine287 » 04.01.2017, 18:42

Super, ich habe die Probleme damit beheben können.
Aber als Laie habe ich mit der Beschreibung "Quelle" erst mal nichts anfangen können.
Gerne noch etwas genauer den Weg zur Lösung beschreiben.
Aber eine super Hilfe!
Genau das gleiche Problem habe ich auch und würde mich über Hilfe sehr freuen!
Würde das Problem mit dieser Methode gern beheben, kann aber auch die genauen Quellen leider nicht ausfindig machen, da ich Laie bin. :(

r23
Beiträge: 1518
Registriert: 18.09.2008, 05:56
Wohnort: Hagen
Kontaktdaten:

Re: Die verwendete Konstruktoren-Methode für WP_Widget ist seit Version 4.3.0 veraltet!

Beitragvon r23 » 04.01.2017, 23:26

Hallo nadine287 :)

willkommen :)

Der erneute Versuch einer Erklärung :)

- Lade per FTP alle PHP Scripte von WordPress auf deinen Rechner.

- Verwende einen Editor zum Beispiel Notepadd++ https://notepad-plus-plus.org/ und

unter Suchen den Punkt In Dateien suchen in den PHP Scripten von WordPress nach WP_Widget suchen.

- In den Fundstellen (Suchergebnissen) nach o.g. Anleitung die PHP Dateien ändern.

Wenn es zu kompliziert ist => eben ein Angebot info@r23.de anfordern und wir beseitigen die Fehler.

Beste Grüße

Ralf


Zurück zu „Wordpress Fehlermeldungen“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast