MyOOS Version v2.4.39 veröffentlicht.

Die Version 2.x ist unsere Entwicklerversion. Es werden ständig neue Eigenschaften hinzugefügt.
Antworten
r23
Beiträge: 1786
Registriert: 18.09.2008, 05:56
Wohnort: Hagen
Kontaktdaten:

MyOOS Version v2.4.39 veröffentlicht.

Beitrag von r23 »

Hallo,

wir haben MyOOS 2.4.39 veröffentlicht

Download
https://github.com/r23/MyOOS/archive/re ... 2.4.39.zip

Aktuelle Versionen erhältst du immer über GitHub
https://github.com/r23/MyOOS/releases

Systemanforderungen

PHP in Version 7.4 oder höher.
MySQL in Version 5.6 oder höher.
Apache in Version 2.4 oder höher.
Das Apache-Modul mod_rewrite.

WordPress 5.8.2


Version 5.8.2 behob ein Sicherheitsproblem und 2 Fehler. Weitere Informationen findest du in den Veröffentlichungsmitteilungen.
https://wordpress.org/support/wordpress ... ion-5-8-2/




MyOOS Shopsystem 2.4.39 - Beta Phase

Wunschliste wurde überarbeitet
Downloadbare Produkte können erfasst werden.
(Lieferung und Bestellung noch nicht möglich!)


Shopbetreiber können nun einen Mindestbestellwert eingeben.
Wenn der Mindestbestellwert nicht erreicht ist, ist eine Bestellung nicht möglich.

Wir haben in unserem Demo-Shop 20 Euro Mindestbestellwert eingerichtet:

Beispiel:
Das Produkt erreicht den Mindestbestellwert nicht.
https://oos-shop.de/shop/index.php?cont ... ducts_id=1




MyOOS [Dumper] v 5.0.13-dev

ich habe die neue MyOOS Dumper 5.0.13-dev veröffentlicht.

Download
https://github.com/r23/MyOOS/archive/re ... 2.4.39.zip

In dem Verzeichnis ~/mod ist MyOOS [Dumper] und kann ohne die anderen Anwendungen installiert werden.


MyOOS [Dumper] 5.0.13- dev
- Upgrading league/flysystem (2.3.0 => 2.3.1)
- Upgrading phpseclib/phpseclib (2.0.33 => 2.0.34)
Wird für SFTP Sicherung per PHP benötigt.


Wenn man ein Speicherproblem mit MyOOS [Dumper] hat, kann man sich nun den Speicherverbrauch für eine Datenbankabfrage anzeigen lassen.

Hierfür in ~/mod/inc/mysqli.php in der Funktion mode_query die Funktion print_mem in Zeile 325 einschalten.

Aus

Code: Alles auswählen

function mod_query($query, $error_output=true)
{
	global $config;
	// print_mem();
	if (!isset($config['dbconnection'])) mod_mysqli_connect();

wird

Code: Alles auswählen

function mod_query($query, $error_output=true)
{
	global $config;
	print_mem();
	if (!isset($config['dbconnection'])) mod_mysqli_connect();
Nach der Auswertung die Änderungen einfach wieder rückgängig machen.


Das Mitglied powerpoint hat uns auf den Fehler in Bezug auf die Nichtübereinstimmung von Groß- und Kleinbuchstaben
hingewiesen.
viewtopic.php?f=41&t=2847


Änderungen für PHP 8.1 support.


Aufgaben auf der Wunschliste: automatisches Update Script



Danke für die finanzielle Unterstützung an:
- pehuha47
- moere22
- Steffen
- Herki


Wunschliste / Künftige Attraktionen

Hast du Verbesserungsvorschläge? Zögere nicht, das Entwicklerteam über das Forum hier zu kontaktieren.


Mitwirken


Wenn du uns dabei helfen möchtest, das MyOOS Projekt zu verbessern, freuen wir uns hier auf deine Pull Requests via GitHub.
https://github.com/r23/MyOOS/

Beste Grüße

Ralf
Antworten